Marker mode not working

Hello.
My pop 2 works fine in all modes except marker mode.
I am trying to scan a large surface and it is impossible. In the preview window the surface appears in red from the beginning and at no time does the scan start.

Did you only scan the metal board?

I don’t see enough markers in the main window. There should be at least 6 at all times.

from what I see the markers are not detected at all, you should not even have the red preview , you should have a red dots in the preview window before you click play button to scan , the markers are also pretty much apart from each other in a regular pattern , you can’t use a pattern when placing markers , they need to be random and much closer to each other .
Try to reduce the ambient light as I see something is blasting from above , and place the object on a black plastic surface like for example black garbage bag .

please make a screen shot when the scanner is in preview mode , to ensure the markers are detected
Preview mode is before you start Scanning session .

1 Like

Hello, this is a screenshot of the preview window in marker mode. A couple of red dots appear at the beginning and then disappear


The same thing happens when scanning an object in Marker mode, the same object in feature mode scans acceptable.

Thanks

Hi @Michalovis , let me check for you the android app to see if there are any issues with the marker mode and markers . BRB

Thank you for helping, but the issue is not only in the android app.
I show a little video from the Revo Scan for windows

Video

Ok I see , this is abnormal behavior , if there was not enough markers you would get a message . So very strange behavior indeed .
I don’t even see any marker turning red at all .

And since you have the same behavior in Android app, looks like the device may not working properly in marker mode at all.

Do me one last favor and try to put the scanning plate of the turntable and use marker mode to see how it behave , you can shot short video as well , it will help out the Customer Service to handle it faster .

I think we have case for @Revopoint3d-Selina to check this out in main time .

Ok, I share a new video: video
Thanks

1 Like

Yes definitely device issue with the marker mode 100% .

You should have zero problems using marker mode in your video , the device is not responding correctly .

I can use a grains of sugar on a black plate and use it as markers , so good it picking up . I even made tests to 1mm markets couple weeks ago without issue .

This is a serious problem as it would also prevent you from proper calibration of your device .

@Revopoint3d-Selina should look into it tonight and give you response for future process of this issue .

Please keep your videos online until Selina check on them .

P.S in main time you can try to increase the gain setting under Depth camera preview to see if the higher brightness improve picking up of the markers or not , if you like of course .

P.S a note about marker mode , when you scan objects using marker mode you can’t pause scanning and flip them on the side to finish scanning , marker mode don’t use any features of your scanned objects for that reason it can’t track the features to align the model , it only track the markers in a one scanning session at a time . .

Hello, browsing these forums I have found the calibration utility as it is not on the revopoint download site. I proceeded with the calibration and the red dots appeared in marker mode. I’ll keep testing but I think I’ve solved the problem.
Thanks for the help.

2 Likes

That’s a great news @Michalovis , you probably will get now also better scan’s results , something was there not aligned the proper way .
But good to know if someone else ever encounter the issue .

1 Like

Thanks for sharing indeed. I did do calibrate my Pop2 and was able to scan some smaller items. Now I try to scan the inside of a mobilehome garage. It’s really horrible, I’ve already placed a gazillion markers, but it seems to lose track/ zoom out / drift etc. From what it picks up…it seems to create a small bend in the surface.

I am wondering if there is a feature scan-mode that could have markers to help it not lose track. It seems it’s now either or…and it’s frustrating to say the least…

Any other tips are welcome as well…

Btw I’m using my phone (Android) with the extra battery and USB-mode

I would never do that on my phone to be honest , the tracking is too bad since the phone is too slow , I had better results in mobile scanning using 8GB android tablet, less issue with tracking .
My phone has 6GB RAM but nothing to compare to tablet when using POP2.

I would rather use a laptop, but ala…I have a Mi 10 Pro with 8.0 GB of ram. It does seem to scan a lot better in ‘feature’-mode than in ‘marker’-mode, that is untill it no longer finds ‘uniqueness’ in the viewfinder… (it also seems it scans more straight in feature mode?)

Hi @Tony did you tried to check the calibration test ? From others users comments it seems like recalibration helped a lot with scanning with the marker mode that relays so much on the perfect alignment of the sensors, what would explains why scanning with feature mode provided better results . Just an idea . Run a 3 tests and see what is the lowest score .

Thnx, I will retry the calibration (although to my memory that was quite a vague process)…

Please run at least 3 tests to see the best value , if the value is above 0.1000 you can try to recalibration.

Before you do save the original calibration files .

When you calibrate ensure there is enough light but not too much on the board , it will helps in calibration , the best if the light come from the same direction that POP2 or from the side , this way the dots will reflect enough to be captured by the camera since it capture pictures while calibration .

You will have 2 steps that are not easy to go through when the board is on the side so a little patience is needed .

The POP2 follows the small dots for the horizontal alignment and not the gyroscope . So if you can’t get the horizontal line correctly focus on the row of small dots as it should be your guide .

Thank you for the extra information, much appreciated!

1 Like