[Windows] Revo Scan v5.0.0.177 (Beta Version)

Screenshot 2023-03-17 115545

Official first public Windows Revo Scan 5 Beta version
this version is valid until March.31

Please download and share your experiences and feedback in the forum
https://www.revopoint3d.com/wp-content/uploads/download/RevoScan5-5.0.0_Beta.exe

3 Likes

Hi,

Strange bug. I have 2 monitors. If I do the following:

a) Opening the app on monitor 1 (laptop’s monitor)
b) Move the app to monitor 2 (larger, and way more resolution than 1)
c) Maximize the app to fullfill monitor 2

Then the app dissapears from monitor 2 and moves back to monitor 1 (taking about 3/4 of the screen).

I’m finding also the program veery slow, specially when handling big files. Don’t know if this is because there is anything running in debug mode.

P.S. I uninstalled the old versions before installing the beta

Maybe becouse of the different resolution of both monitors , the Beta do not rescale proper yet , and the recommended resolution is 1920x1080 , try to set the same resolution on both monitors and try it again to see of it behave the same way then we know if it has to do with the different resolutions or something else .

I was handling big files , the speed actually for me was much faster than in old Revo Scan or Revo Studio , there is some processing time involved if the object was over scanned , but with a simple 360 degrees per scan angle I find it rather very fast compared to anything else before .

The textures can sometimes take extra time but the rest is not bad.
Of course the speed will be never the same on every system , it depends of CPU, RAM and Hard Drive type and the speed the CPU can write down the data to it.
Right now the processing time in RS5 for me compared to Cloud Compare is a light speed.

On my workstation I have no complains , but on my i7 8gen tablet /pc it can take some time and much much longer that I wish , especially when scanning with MINI … Range scans processing the fastest , but I deal here with 2 different systems .

Next time include your system specs , it would be much easier to collect the feedback and bugs and compare. To see clearly if there are some bugs lurking or not .

I found a bug that specific to my setup
i have a big monitor (5140x1440 resolution) and revo scan is like this when opening it

is way too big, cant use it i have to turn down resolution to 2560x1440 for the window to fit.
dont scale ui by resolution, scale by PPI. this fixes it
or make the window resizeable by dragging corner .

also when i drag the app to the other monitor (2560x1440) it disappears but is still open.

revo scan 4 and studio worked fine

rest is functioning so far, tracking as usual a bit wonky but overall performance (frame rate) went up a noticeable bit. im using a pop2

Sure,

These are the specs:
CPU: 11th Gen Intel(R) Core™ i5-11400H
RAM: 32Gb
Graphic card: Nvidia 3050ti (4GB)
OS: Windows 11 22H2
Monitors:
1: Integrated (1920x1080)
2: DELL 2723qe (3840x2160)

I tried to equal the resolution of both monitors to 1920x1080, but same result.

I recorded a small video, I hope it is visible:

1 Like

Again not a bug , the Home tab is not a full screen and it do not adjust itself to the proper resolution , I would put it under design feedback/ suggestion
It was not designed to rescale itself the way it should .

Tracking actually improved a lot , and the speed of POP2 reaching over 12.6fps in feature stitching mode what is a big win over preview 10fps , the Marker Stitching mode frame rate is much slower from nature but still working as it should .

Of course the statement will change from one system to another including connection etc… slower frame rate will always affect the tracking and stitching of the frame cells .

That is great , thank you @krofinski it will be very helpful.

Like another user I was reading here earlier, I am not able to install the Beta (or not so far).

Downloaded the file many different times (at first I thought the file was corrupted). Now I’m able to run it, choose language (English) I then click ok and that box disappear but then it just hangs - doesn’t take me to an install. I have the icon in the taskbar that looks like an install but when I click on it nothing happens. When I try to close it, it says ‘are you sure you want to exit the current installation?’

Any ideas of what I can try (other than the obvious machine reboot, which I’ve done)

I am running Windows 11 64bit.

Hi @cmw1985 you should have open window all the time while installing , it takes just couple of seconds .
I have no idea why it don’t install on your system to be honest , I had no issue on my Win10 or Win11 .

Something blocking the installation on your system … anti virus program maybe ?

The team is offline until Monday so I can’t reach to ask them .

Thank you for your reply. I have 0 idea what the actual issue was after a whole day of trying yesterday, but…it randomly started working as it should. I now have it installed and look forward to testing it out and providing my feedback - many thanks!

1 Like

The window does not scale properly to my (large) monitor.
I will wait with more testing until this is fixed.
But for what I could see so far it looks like a big improvement! Especially the integration of scan and studio will make things a lot easier I suspect.

1 Like

I don’t know when it going to be adjusted since it is still a Beta version .
And yes the full functionality is finally here in one place as we all wished for and going to improve from this point , as there is still a big room for improvement and additional features .

1 Like

Thank you for letting me know , please provide feedback in the thread posted by Cassie , or you can start your own thread under Support and Feedback / Suggestions including your RS5 Beta version number and your computer specs
It would be very helpful in making the official version better as any suggestions and ideas are welcome .

Thank you in advance :blush:

Maybe I’m misinterpreting the nomenclature, but I do not see the ability to close a file, only to delete it (or does that mean to delete it from the Project Index?).

Do you see an X in the Project line on the right side ? , That’s how you close the project .

If you delete the scan , it will be deleted permanently from the current Project session.

Starting new Scan will create a new empty Project and then you can collect your scans in this project/session , if you deleted or closed the currently Project.

The Project represent a session that can include many scans of your object.

Project: session with multiple scans, 1 or more.

1 Like

Is there a way to import previous projects to the new versions install so they will be on the 1st screen and not have to go hunt for them.

1 Like

Unable to successfully transfer a file from iPhone v5.0.1 to Windows v5.0.0 (2023-3-13 download). The devices will start sharing and then immediately fail. Both connected to same network, and I’ve tried multiple networks with the same result.

iOS 16.1.1
Windows 11 Home version 22H2

First test scans done with my mini. I’ll focus solely on the scanning part.

I can see a bump in the overall quality. The tracking has improved A LOT. Not marginally but A LOT. I can see that now the algorithm is able to track correctly with way less overlapping than before. I suspect it is connected to my previous observation about memory requirements and slowness. When I reported that I was opening a piece that with revoscan 4.3.1 took me about 8 rotations to get it 100%. Now I was able do the same with just 3. The explanation from PUTV now makes fully sense to me.

The Android-PC interworking is also great. This is what I see when I open my android scan on the PC (scan made with pop2). It is showing me .43mm in the fuse part (most likely what the phone was able to achieve)

I can fuse it again, this time at the max quality (0.1), and the improvement is visible, it really works as promised.

I found great that now it is possible to interact with the turntable in the middle of a scan, but perhaps I’d do it a bit differently: Things I’d change:

turntable

a) This is what I can see when the turntable is already on. If I change the settings, they are applied immediately after leaving the sliding bars. I would change the start button (which does not make any sense at this stage, because the turntable has been already started), label it “Apply”, and activate the changes only after clicking on it.

b) Would be great an indication of when the turntable has done a fully 360 round. Or perhaps a setting to pause a scan every 360º round (even better, being able to set the XY angle too, if you don’t need a fully 360 round), so that you can readjust the turntable and then continue.

That was all for now. The SW is clearly still a beta, but fully functional and a quantum leap comparing to the previous versions

2 Likes

The old projects have a different extension than Revo Point 5 and at this very moment can’t be imported beside fuse and mesh files from old projects .
Hopefully this issue will be resolved soon as I would like to access my old library .

1 Like