[Windows] Revo Scan - V4.0.1

Dear users,

A new Windows version of Revo Scan is available now!

Download link:
https://www.revopoint3d.com/wp-content/uploads/download/Revo_Scan_for_win_v4.0.1.20220417b.zip

[Updated]

  • Enhanced exposure hints in the Depth Camera, red for overexposure & blue for underexposure.
  • Administrator authorization no longer required to run the software.
  • Optimized batch processing of fuse and mesh operations.
  • Added progress display for batch processing.
  • Added “View model” feature under the model list.
  • Optimized the UI.
  • OBJ-format models now exported correctly.
  • STL files can now be exported after meshing.
  • Fixed various small bugs.

Best Regards
The Revopoint Team

14 Likes

Best upgrade :v::v::v::v::v::v::v::v:

1 Like

Excellent Upgrade ! :+1: :+1: :+1:

1 Like

Missing the “Auto” check box under deep camera as before. What is best way to find best settings?

@Obicom

It is not missing , it is not needed anymore , you have now 2 indicators blue and red to precise setup it correctly , Auto mode never works with all objects .
The blue will indicate the gain is too low , and the red will indicate you are at the edge of gain setting it is about to mess up with your tracking .:joy:

The best setting is when there is no blue or red in the Depth Camera preview , but if your objects has different surfaces like black text printed it may show as blue so you know you will need to scan it after again at higher gain settings to complete the scan .

There is never one setting for everything , but as long you keep everything gray in the preview you going to have perfect scan .

2 Likes

What to say…
Tested now for 2 hours the new V4.0.1. and it´s really frustrating…
The half of the time the software crashes when I want to do the second scan from different perspective
The other time it doesn´t find any alignment any more with the second scan
The test was done with turntable and feature mode.

@Skyrider I used it for almost 10h the day it was released , never crashed on me , scanned small stuff and full body as well . There is something about picking up with the alignment , it needs more time when doing second scan in the same session , try to change the mode , feature mode has a little scan window area,it needs the whole object to be in preview window . The most stuff I am doing now are in Face-Head mode for most objects , less frustrations , I reserve the feature mode for objects that do fully fit in the preview window of the Depth Cam .

I tested it some hours more…
It always crashes when ry to do the second scan, so I avoided it, try to load the model into new scan but never aligned.
I tried out Face Head mode as you mentioned but results were less good then with feature mode…
The objects I´m scanning fit into the preview window.
Rings with chalk spray on a little stand on turn table

1 Like

when it fit then I see no problem , I wonder why you crashing , did you fuse the point cloud after first scanning ? as that is what I am doing before second scan in the same session , maybe it will helps

I tried both “several” (many) times. When not fusing it crasehs always when fusing before second scan in 95 % of the time.
I tried now with Head, Face, feature
always the same…
So, after some hours I gave up wasting my time and tried to match 2 scans in Revostudio.
Hard to find some instructions how to use it, not on the offical revopointsites…
I think I read some instructions you made here in the forum days ago…
Unfortunately after loading the second scan into Revostudio it also crashed.
I´m done for today…

1 Like

@Skyrider it looks like memory issue to me , but I am just guessing , we will have to wait until Monday for @Revopoint3D-Cassie to check this issue with the technician

Some of my models need 8GB of memory , on my phone with 6GB RAM I can have maximum 1600 frames before I have to fuse it to continue scanning , but so far it is steady , and my workstation has 64GB Ram and 12GB Vram so I am good.
I hope your issue get resolved soon .

Just scanned a plaster cast of a model tire using software 4.0.0.
I would say it is a perfect scenario for a 3D scan.
It went pretty good so far - good on a Revopoint scale.

Installed 4.0.1 and never touched the physical setup.
With 4.0.1 and the same model it always loses track and fuses crap into it no matter what settings.

@Revopoint: Continue releasing new hardware and forget to focus on frustrated users dealing with a buggy software will give you short term sales, but no future.
Just read this thread. After only a few hours users complain about crashes. This leads me to think that you guys either did not test enough, or took the risk of releasing another incomplete software just for the sake of releasing it.

At this point I would not recommend your product to anybody.

@jkust the software 4.0.0. was bad it do not fused the point cloud frames correctly , it was very bad actually and each point cloud needs a clean up before meshing regardless, I only used Handy Scan and Android because of that issue , I do not experience any problems with Software build 4.0.1 regarding point cloud but I see some tracking issues that was not at this level before , not when scanning single 360 degree turn but after fusing it has a hard time to find the track again if the model changed position and that is what changed for me.

The update was necessary to fix the point cloud mess and other stuff , but it broke other things on the way .

The crashes are related to memory and graphics cards and messy systems, I never experienced one single crash yet and I scanned 4000 frames models in one run without fussing , producing millions of poly mesh.
So this is system related and not the software.

2 Likes

Sorry when I ask…
…if this would be system problem and not software

why are so many people have same crash problems and don´t get aligned scans
And why other programs don´t crash
For sure it is some software problem

1 Like

@Skyrider if that was the issue I would crash it daily , as I processed so much heavy data running it daily for many hours but it never happened for once, how do you explain that ? I do agree the tracking got worse as I checked the functionality yesterday compared to HandyScan 4 , and indeed HS4 tracking it better than last Revo Scan build but it only happening with specific objects, the tracking in marker mode works just perfect once I updated the plate with my own reflective markers as the original do not pick up as it should.
I am not here to butter anybody. If I have issues I am loud about it and if I have issues I use the bug report option in the software to report it directly to the source.

The Revo programmers do not read your complaints in the forum , if you have issues, report the bug proper way so it goes directly to them .

And if there is an emergency you’re gonna have an appointment and the programmer will check it personally as they did for me when I needed it early in time and the problem was solved .

I do understand your frustrations , and I wish I could help you fix it but here in the forum it is all we can do , just talking to each other.

If you want faster help, create a new thread in the support section of the forum, include all your system information and describe everything that is going on with your issue , it would be much easier for Cassie to forward it to the technicians and find a solution .
Not just saying " I am crashing " , how are you expecting help based on that information ? There may be a million reasons for that , not every system specification is the same and you are dealing with a heavy load of data shutting thousands of pictures in minutes and processing them at the same time .

I hope your problems get solved soon .
Best Wishes !

1 Like

Sometimes the best way to solve an issue is “the process of elimination”, switch computers, reinstall software, try different software, etc

1 Like

@Miamijerry I saw many users that had crash issues related to everything else than the software itself even @brizz reinstalled windows 10 and his problem was solved . If the software was that bad we would all experience crashes one way or another . Not saying it is all perfect because it is not and lots of work still need to be done . But the last update was necessary as I could not work with the point cloud mess it produced.

2 posts were merged into an existing topic: [Windows & Mac Version] Revo Studio - Beta Version V3.0.5.16 - Updated on April 24

Much much better! Great update! However, let’s keep on improving software!

2 Likes