RevoScan V4.3.3 has a library issue and wont start OSX 10.13.6

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/libosg.161.dylib
Referenced from: /Applications/
Reason: no suitable image found. Did find:
/Applications/…/Frameworks/libosg.161.dylib: cannot load ‘libosg.161.dylib’ (load command 0x80000034 is unknown)
/Applications/…/Frameworks/libosg.161.dylib: stat() failed with errno=1

Binary Images:
0x10e2fb000 - 0x10ee86ff3 +com.Revopoint.RevoScan (0) <7E789699-0DDC-3C64-A4F7-6BFD7C1C2350> /Applications/
0x114d0a000 - 0x114d54acf dyld (551.4) <8A72DE9C-A136-3506-AA02-4BA2B82DCAF3> /usr/lib/dyld
0x7fff28b82000 - 0x7fff28b82fff (6.11 - 22) <78E6C28E-4308-3D10-AD14-0CBCF6789B3F> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
0x7fff28ed0000 - 0x7fff28ef9ffb (1.0 - 1) /System/Library/Frameworks/CoreBluetooth.framework/Versions/A/CoreBluetooth
0x7fff2b4bb000 - 0x7fff2b881fff (6.9 - 1454.90) <8EA924F3-ADAE-3F4B-8482-8B11C027D9A5> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation

Model: MacBookPro8,2, BootROM, 4 processors, Intel Core i7, 2 GHz, 16 GB, SMC 1.69f4
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Graphics: AMD Radeon HD 6490M, AMD Radeon HD 6490M, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0000, -
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x0000, -
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (
Bluetooth: Version 6.0.7f10, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: CT1000MX500SSD1, 1 TB
USB Device: USB 2.0 Bus
USB Device: FaceTime HD Camera (Built-in)
USB Device: Hub
USB Device: Apple Internal Keyboard / Trackpad
USB Device: BRCM2070 Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: IR Receiver
Thunderbolt Bus: MacBook Pro, Apple Inc., 22.1

Hi Stux,

It doesn’t start for me either on a Macbook 2010 running that same OS version, which is the last fully patched version of High Sierra, the newest OS our laptops can run.
I would like full API specs for the scanner hardware I bought (pretty please :grinning:). No need to give any guarantee about the firmware spec not changing. I have bought a Mini, what did I buy exactly? It looks gorgeous.

I’m expressing solidarity, I don’t have a solution for my daily laptop :innocent:. I would like the Revopoint scanners to be Open Source (that might be too much of a burden), so a documented but unsupported API that may change at any time would do! I got my Revopoint Mini in the first batch of Kickstarter, and didn’t use it until last month as the installer I tried (V5) said my Mac OS was too old and unsupported, I didn’t try V4 until today, which I tried just now and that won’t start. I then looked for the Revopoint Linux driver, and there wasn’t one. So my Mini went back in it’s box for many months :smiling_face_with_tear:. My 2010 Mackbook is really good, 8GB ram, 4TB SDD, acceptable battery life, a new Apple laptop with that spec is out of reach financially and much more expensive than a Mini.

I planned to use OCLP so I could run Ventura and run V5 on the Macbook. In the end I dug out my old Cheesegrater Mac Pros, Upgraded those to Monterray using OCLP (USB issues with Ventura meant it was flakey, I would need a 2.1 USB hub), these old Mac Pro machines run V5 like a champ. V5 maxes all the cores, and barely uses more than 8GB of my >16GB RAM.

Ventura (Via OCLP) does run on my 2010 Macbook using OCLP, but no metal graphics so I am sticking with Sierra as the day to day OS on that as it is faster and stable without hacks.

Hi John,

I currently have a work around - bootcamp (early 2011 MBP 1TB SSD 16GB ram). Currently its running Win 8.1 pro and will run revoscan 4.3.3, it does have a .dll error at start up tho but if you ignore it for 10 seconds it will boot. I just rather not have to swap OS all the time!

By no means am I an expert in any way with computers (just wasn’t me growing up - had to learn later). I’ve just bought myself a 3d printer and a BTT main board I’ve had a very very very steep learning curve with visual studio code, marlin and the like - still not sure if I totally get it yet. I have inspected the OSX 4.3.3 package and located the the library section and it is missing the specific .dylib but re-installation doesn’t fix it so I maybe guessing since it’s under the no longer updated section they wont do anything about it or has it intentionally been left out??

I think if they were to keep supporting the older operating systems they would probably have more users, a new M2 13inch MBP here in New Zealand is $2500nzd (only know because I bought my wife one!) This 2011 hand-me down still works fine I can run MatterControl and Prusa without any issues.

Hi Guys, Revo Scan 4 is no more supported , please install the latest version of RS 5.2.4 .

There will be no more updates available for RS 4.3.3 in the future and that is also not the best version to be used , if you like move to version 4.2.0 it was the latest best version to use only with POP, POP2 or MINI , newest scanners are no supported by the old versions and may not work optimal or not at all.


That would be good but there are no downloads for 4.2.0 on the Revopoint site.

Do you have a link to download to V4.2.0???

As stated above we can’t use RevoScan 5 as our computers are about 12 years old - the hardware is more than enough but our operating system versions can’t be updated anymore.

Hi @stux
I am not home and on the phone , but I will see what can I do with the download link of v.4.2.0 windows only . It should works fine on your system as it support win8 as well .

Thanks for the reply,

V4.3.3 works on windows 8.1 fine…

I prefer not to swap operating systems all the time between OSX and Windows.

Saying that can we get the 4.2.0 download link for Mac OSX?? as that would be better.

or even the complete “Frameworks” folder with all the “.dylib” files inside (for OSX) as I can recompile at my end.


1 Like

I don’t have MAC version since I am windows user only . I will see tomorrow evening when the office opens, if they can provide me with MAC version .

1 Like

Any luck finding the MAC version?

Sorry nothing yet … I am on holidays until tomorrow, nobody of my friends have MAC 4.2.0 either so waiting for the team


How are we going on finding a MAC version?


Hi @stux , did the support forgot to contact you ? They told me they will contact you in your MAC case as they said RS5 should works without issues on your MAC …
They did not provided me with MAC 4.2.0 as they said it is not nesesery…

I am lost here … pls help me out

No support have not contacted me yet

I will reminds them on Monday when they are back in office .

1 Like