RevoScan 5.3.0 - Issues

I downloaded version 5.3.0 and the ressults with previous scans with MINI are a LOT WORSE.
I tried to do the same process without using the new RAW edition capabilities, and the ressults are much worse.
How I can go back to previous version?

Do you mean editing scans you had done with the mini before or executing new scans?

Did the software ask to upgrade the mini firmware like it did for me with the POP3?

@PUTV @Revopoint-Cassie

I just came home not had time to test but I will with my coins to see difference.

Just install.preview version you downloaded early , I always keep old one just in case

I don’t know for MINI , I worked testing it only with new POP3 firmware that I got early for testing purpose , I will check .

The WB require change in the firmware to work correctly .

I was exited to test the new RAW edition and the new MERGE, I tried with some old projects and the final results where not at all what I expected. It seems everything points to make the scan much cleaner but it end up making holes everywhere and that did not removed noise in the process.
So I end up with a worse mesh, losing many details and keeping noise or adding more.

The software only told me that there was a new version available, but nothing about the MINI firmware.

sorry what is WB?

White Balance

Ok I went back to 5.2.3 but now the file it is stuck in fusion processing… I guess my RAW is no more compatible with the previous version?

Ok I found and installed version 5.2.4 same thing… it gets stucked on fusion processing, advanced or one click… but for some other projects that I didn’t edited the raw files it goes well, so I guess I would only be able to work with it again in version 5.3.0

I will try to install both versions.

I actually tested with MINI , and the results are better and smoother

Much much better

1 Like

The white balance works fine with MINI , all you need to set off the Auto Exposure off and it will not change the white balance , it does not have the super function as Inspire or POP3 maybe becouse not firmware is updated yet , but it works .

with new projects it makes wonders. Even they added the threshold function to detect surfaces that I mentioned!!! :star_struck:
But I tested first with an old scan, I edited the RAW data deleting all the noise before the fusion process and I end up with a lot of holes in the mesh and then I wasn’t able to use that RAW data on the previous version… so I guess I will have to scan the object again… so maybe it was an isolated issue, but you may want to test that. I did the same thing with two other old projects and the results where not better. But then I tried to start a new project and it was good.

The function always was there but pls don’t use it with MINI , it will affect the results and make things jumping resulting in less accuracy .

I started new project and scan , edited the RAW data as well removing some ghosting and lose points from the frames resulting in better fusing , when working with MINI you need to eliminate as much you can before fusing , it allows the algorithms to produce better results without the extra data .

If you scan too much area with MINI it tend to cut on the accuracy if the scanned area is too big since it produces too big model size reaching the limitations , now you can avoid it and focus your resource on what is really important in your scan .

I noticed the same thing with Inspire when I loaded up some scans I did last week with 5.2, edited the raw data in 5.3 and fused. Same issue you describe. Loads of holes everywhere after editing the raw data.
Make a new scan and it’s perfect though.

I guess Revopoint changed something about how the data is recorded.

Although, I just tried again on the Mac version and it fused perfectly. I’m wondering whether it’s a bug in the Windows version.

I’m on the mac version

Interesting. I will experiment with some more of my scans. Give me 10 mins or so.

The function always was there but pls don’t use it with MINI , it will affect the results and make things jumping resulting in less accuracy.

It was? well now I set it to 100% and I scanned the Aztec Calendar again, and I didn’t even had to use any external aid at all. It still have noise tho… but the workflow was much easy, I scanned it plain on the table, one full turn on one side, and one full turn from the other side and the ressult was even better than the previous one.

OK, got the Mac version to do it too.

Here is the 5.2 fused model

The raw data in 5.3

Cleaned up raw data

And fused in 5.3

I think we have a problem. With editing the raw files being destructive, I think we need a disclaimer or something that advised not to edit raw data of previous projects.

I’ve got the exact same thing. BUT I remebered that I imported the raw data from my phone, and imported it again and test 2 things:

  1. Continued until I’ve obtained the mesh without using RAW data edit.

If you bypass raw data edition, you may get something similar or better than previous version.

  1. Clean raw data… then continue…

If you USE raw data edition you will end up with…

So… it’s not only what you had previously scanned on 5.2.x but also whatever you will scan in the future with ( at least for me ) the IOS app. Since it does’t care if you scanned it today or tomorrow if the app is not updated the result will be the same.