Revo Studio Black screen RTX 4090

Hi, i have a pop mini.

On my PC i can not use revo studio, i suspect one of the following:

  1. Issue between Revo Studio and my driver, or;
  2. Issue with per app graphics settings in Nvidia control panel.

I have a Nvidia rtx 4090, and dont have similar issues in any other software or game.

Things i have tried:

  • Completely uninstalling, cleaning registry and installing latest Revo Studio.

  • Completely removing graphics driver and GeForce now etc for the latest as fresh install.

  • Fully updating windows (11)

  • putting an old rtx 2080 ti in the machine

None of these things made any difference.

I have seen on some similar threads the suggestion of what basically amounts to, just get a newer /more powerful machine, or completely wipe and reinstall the OS, or just use a different machine.

This is a very new very new, expensive, powerful machine, I dont think those recommendations are helpful or practical.

What should i try?

I once previously when my pc used the 2080 ti still, had a similar problem in autodesk fusion 360, which was solves via changing a graphics related setting in that application. Not sure if that helps.

I have also tried:

  • running as admin
  • running in compatibility mode for windows 8, 10
  • running on a different monitor
  • connecting to monitor via hmdi, and display port

The software opens, i can see the menus and import a mesh (I assume based on buttons at the top not being greyed out).

But the big window used to show the scan is completely black.

The other main specs of my pc are:
Cpu: amd 3950x
Ram: 32gb

Hi @NoImageMeSad

There is nothing wrong with your machine.

Please right click the Revo Studio icon and see on what GPU it is running , if it is running on your RTX 4090 you need to roll back the last graphic driver , if is not using RTX GPU switch it and try again .

In most cases the Nvidia driver is the issue , it is happening from time to time and Revo dev.team can do nothing about it .
So check the GPU that Revo Studio is running on , and if is correct try older graphic driver or switch to Studio graphic driver .

1 Like

I rolled back a rev for game ready driver, no good.
Then i tried clean install studio driver, same.

Whats a good alternative software to try, preferably free?

I also have tried various different scan files, incase the one i was using was corrupt or something, which didn’t change anything.

I didnt think that was the issue because i was able to open it in fusion 360 and blender but figured i might as well try.

Could there be an environment variable i need to add to my pc?

I saw for some other software with qt & opengl this can be used to force certain properties that sometimes have got things working for people with similar issues.

Im not sure how to check which gpu is in use for the app as requested above, but my cpu isnt an apu and doesnt have a built in gpu. The only gpu in my system currently is the rtx 4090.

In this case the right GPU is used , to check what GPU your software is using , you just right click the Revo Studio Icon and you will see the option in the menu list. However if your system only runs one , there is not need for that .

I run here out of ideas , as most issues that cause this was a GPU that do not support OpenGL 4.0+ in general, but that is not in your case here .

As a free alternative you can use Cloud Compare software , it is more advanced but really great app and at no cost .
I use it a lot .

The Revopoint dev.team is back from holidays on Jan.29-30 so they may have an answer to your problem , until then try Cloud Compare.

Did you try loading the program without the GPU?
I know on mine my rtx 3050 cause the software to glitch. I now have it setup to run on the Intel cpu only.

He can’t do that Jermaul ( @NoImageMeSad : but my cpu isnt an apu and doesnt have a built in gpu)

GPU need to support OpenGl 4.0 at least
So it will not run on CPU only without a GPU.

Thank you for the support everyone, om going to try a different software i think at this point and will report back.

1 Like

Try Clouds Compare , it has very good merging tools to finest perfection

Here is simple tutorial I made for Cloud Compared

All, i appear to have solved this.

I was doing some reading about how QT uses various versions of OpenGL. (Qt for Windows - Requirements | Qt 5.15)

Relevant sections are about half way down the page and talk about using -opengl dynamic which might be an idea for the Revo Studio team to consider so that peoples apps can choose at runtime the library to use.

I used to the tool “Dependencies” from github to load Revo Studio can check what OpenGL.DLL it is using. (GitHub - lucasg/Dependencies: A rewrite of the old legacy software "depends.exe" in C# for Windows devs to troubleshoot dll load dependencies issues.)

Seemed to be C;\WINDOWS\System32\OPENGL32.dll which checked out as far as i could tell.

from the QT page:
" When configured with -opengl dynamic, neither Qt nor the applications built using qmake will link to the opengl32 (standard desktop OpenGL) or QtANGLE libraries. Instead, the appropriate library is chosen at runtime. By default, Qt will determine whether the system’s opengl32.dll provides OpenGL 2 functions. If these are present, opengl32.dll is used, otherwise the ANGLE libraries (libEGL.dll and libGLESv2.dll) will be used. In case the ANGLE libraries are missing or initialization fails for some reason, an additional fallback is attempted by trying to load opengl32sw.dll. See below for details.

The loading mechanism can be configured through the QT_OPENGL environment variable and the following application attributes:

  • Qt::AA_UseDesktopOpenGL Equivalent to setting QT_OPENGL to desktop.
  • Qt::AA_UseOpenGLES Equivalent to setting QT_OPENGL to angle.
  • Qt::AA_UseSoftwareOpenGL Equivalent to setting QT_OPENGL to software.

When a certain configuration is requested explicitly, no checks are done at application startup, that is, the system-provided opengl32.dll will not be examined.

The dynamic loading has a significant impact on applications that contain native OpenGL calls: they may fail to link since qmake no longer automatically adds opengl32.lib or libGLESv2.lib. Instead, applications are expected to use the OpenGL functions via the QOpenGLFunctions class. Thus the direct dependency on the OpenGL library is removed and all calls will be routed during runtime to the implementation chosen by Qt.

**Applications that require a certain OpenGL implementation (for example, desktop OpenGL due to relying on features provided by OpenGL 3.0 or higher) should set the application attributes Qt::AA_UseOpenGLES or Qt::AA_UseDesktopOpenGL before instantiating **QGuiApplication or QApplication

Long story short i looked in my environmental variables and saw i had one for compatibility of a different tool that had set QT_OPENGLtoangle.QT_OPENGL to angle

Solution:i didnt set it to desktop or anyhing, because i figure that could give me some other compatibility issue in another app. I just deleted the variable all together and now it all works.

Hi @NoImageMeSad ,

Thank you for your update. It is valuable information. :+1: :+1: :+1:

I sent this post to our dev team, and we will discuss it to see what we can do to improve it.