Revo Scan can't find dual axis turntable

@Elproffesore no problem and sorry , I was thinking you talk about me since I am beta tester , but me or other testers from our group do not experienced any of the issues some of the users here have and it is hard to reproduce the issue if everything working fine right? it is basically impossible .

since all computers systems are unique despite the fact they running the same OS in many cases there is no one solution for all.

I guess you will need to wait for the developer team to help you out here , as most ideas that was available you tried already without success.

I am sure @Revopoint3d-Selina or @Revopoint3D-Gena will check on you once they start working tonight and ask the team for a new solution to this issue .

No, Revo Scan won’t recognize the turntable. I unpaired Bluetooth and got latest firmware in my POP2 but still no joy. Turntable settings are greyed out in Revo Scan

The feature to connect dual-axis turntable and pop2 will be released soon. For now, it’s not compatible with pop2. So you can’t see it on the Revo Scan if you use POP 2. Please bear with us for more time. Thank you!

The newest version to be compatible with the dual-axis turntable should be v4.1.1.20220930b. Could you upgrade the software and try it again?

This is the version I’m currently using.

As @Revopoint3d-Selina said the POP2 and DATT Control is not yet supported with the latest version of the Revo Scan software , if you have an android phone you can try my phone app to control the DATT until they add the POP2,

1 Like

I installed that version.
image
Still no joy. My laptop can see and pair the device


but the Mini can’t see or pair it. It doesn’t see ANY bluetooth devices in the ‘other devices’ list either.

I just want to be certain, but you did unpair the turntable from your computer first, right? If the turntable’s bluetooth port cannot even be seen, that indicates it is paired to another device (yes, another explanation would be that the two bluetooth devices are not compatible, but that seems unlikely as they are both Revopoint issue).

I have a bullet speaker that, somehow, got paired to the neighbor’s audio system, so I have to go through a very specific sequence of setting my phone to connect to the speaker before I turn the speaker on.

Yes I unpaired it from the Laptop and even turned bluetooth off on the laptop - still not working.

I am beginning to think my Mini’s bluetooth circuit may be bad.

I was trying to think of something else that had a reasonable chance of preventing operation, but this does seem most likely.

I don’t have a turntable to test, but did you try the Android app that one of the other users published?

Hi,
Got it. I have forwarded this to our team and see how we can help.

Would you like to have a meeting tomorrow at 4:00-7:00 PM UTC+8? We can help to check out the problem. Or please tell me when you will be available for the meeting.

I am available anytime that time range.

I just received my kit and I’m having the exact same issues as above. Tried everything in this thread and it still won’t connect. I’m also on Mac OS most recent version. I’ve tried every sequence possible for turning things on. nothing.

I hope you guys can figure it out today. Looking forward to how your call goes.

Problem not solved yet. I tried everything but no result. Actualy i use turntable with pc via browswer.
Is there any way to check if mini bluetooth is working?

Yes you can see it if you turn on BLE on PC or your phone … ( XXX Products) or something like that , sorry forgot the exact name .

Maybe one more thing.

Press the Windows Start key and enter “Windows update”. If it prompts, let it run, then reboot and see what happens.

Thank you for your reply. I can’t see mini with both my smartphone and tablet.

Which components should be updated?

If you can use DATT with the browser on your PC , you should have no issues to use it via Revo Scan , there are 2 options , use it via PC Bluetooth or via MINI Bluetooth.

As long you updated the MINI firmware successfully to activate the DATT settings in Revo Scan .