Revo Mini stuck on red light

Hello, my Mini is stuck on a red light on the back of the unit. I’ve tried plugging it in to mutiple computers with no change. It was working fine a few weeks ago but haven’t really used it in awhile. Is the scanner dead? I tried 10 button pushes and also the procedure where I hold the button down on power up until the light is red, press again on green and wait for it to turn blue, and the firmware was reinstalled. Still red afterwards.

EDIT: Tried the firmware upgrade using the procedure outlined here: Revopoint Mini no longer boots - Support & Feedback / Customer support - Revopoint 3D. The firmware upgrade runs and at 50%, the light turns red. It takes awhile but says it completed successfully. The scanner reboots and is back to red again.

Follow steps from my tutorial to restore the update and then try again , don’t skip any steps , power your MIni only with battery or AC , no computer

I assume you mean using the mobile split cable and powering with AC power and then plugging the data cable into the computer?

No , do not plug any cable to computer , the reboot need to be done while the MINI is only powered .
Follow the tread , it will explains each step

That’s not what I stated. Rephrasing it:

  1. Use the split cable and plug the power end into AC power. Do not plug the data in. Perform steps 1-4.
  2. Step 5: Plug the data cable into the computer for the firmware prompt to happen. Will Revoscan 5 do the same prompt?

It’s insane to me that a scanner which has literally been sitting doing nothing for a few weeks needs to be fixed.

You can only perform firmware update using Revo Scan 4.3.1

This is not for using Revo Scan 5 .
You got it correct .

The reset need the power only , after that you connect the data cable and start RS4.3.1 to finish the firmware update

Firmware update can be stressful sometimes for some for no reason .

Your device should be not stuck at red light by itself if not used for long time , it only happens if it get stuck at reboot ( or after firmware upgrade in most cases )

If you follow the all steps from the tutorial and nothing change , I will move your thread to Customer Support as it will need technical attention to determine if the hardware is ok, but the office is closed for the weekend so not early than Sunday evening after 9pm EST .

Thanks - I do appreciate your help. I did email customer support with the “get log” file as well.

1 Like

That was a good move on your side , I will tag @Revopoint3D-Gena for the assistance and alert of this case.

I’ve not heard back from Support - emailed them on Friday morning US eastern time. How long does it usually take them to respond?

Hi @IndyColtsFan , they should have responded to you last night . But since it was weekend, maybe too much emails accumulated .
I will tag again @Revopoint3D-Gena and @Revopoint-Agnes

1 Like

@IndyColtsFan Hi, we seem didn’t receive your log files, could you please send them again with the link to the forum? It will help us to check which email is from you, thank you in advance.

Yes, I resent them to Is that correct?

1 Like

Yes without the small dot after com.

Yes, that is where I sent them and resent this morning. Thanks

They are back in office around 9-10pm EST , (9-10am) Beijing Time

1 Like

I’ve reset and updated this scanner probably 10 times at this point. I did try it with the 2-in-1 with the A cable end plugged into AC power. The same result - the firmware updates “completes successfully” but when the scanner reboots, stuck on red. I emailed the logs to support again this morning.

The level of support provided so far has been horrible. “Watch this video to do the reset procedure” isn’t acceptable support when I have clearly stated I have done those steps at least 10 times including yet again this morning and the response: “Watch the video and reset it and apply firmware.” At this stage, Revopoint support is wasting my time. If you can’t fix it, replace it.

This morning - after I CLEARLY indicated I ran the process in the video 2 TIMES and send log files, the response from support was: “The firmware failed. Can you watch the video and do those steps?” after I clearly stated I did that. Every single time I update the firmware, the light on the scanner turns red at 50%. The process completes and says it is successful. I’m not going to keep running the same process hoping I can get it to work when I’ve done it at least 10 times.

I don’t know how much more clear I can be here folks - I’ve followed the procedure in the video multiple times. Every time, the firmware update says it’s “successful.” Yet, the scanner doesn’t work and the light is still red. I’m not going to continue wasting my time doing something which isn’t working. I’ve explained all of this to support.

Hi @IndyColtsFan it is stuck on update , if it is red … normally it should reboot back to green , but if it is red , it has not completed its reboot and your mini waiting and continue the loop .

@Revopoint-Agnes the device is stuck on reboot and can’t be reset the normal way, I think it is time for a replacement.

I just got a call from Revo. They’re going to look into replacing it.

My concern, however, is this - the scanner literally sat for weeks without me using it (it was plugged into my computer’s USB) and this happened. Any ideas what caused it? I don’t remember any firmware prompts and I have used it since I last updated the firmware, so I’m puzzled what caused this issue.

I have many devices , but never experienced something like that unless it was trying to update one of my MINI , I was just able to update the firmware successfully after reset.

But at it’s own , never , I wonder too why it could not reboot.