POP2 Wifi Host not working after a few uses , Blue light

Hello everyone,

I’ve managed to get great results on 3-4 scans after following amazing tips from this forum (you guys rock!).

Revopoint Pop2 was purchased in late Dec. I was using it in two modes:

  1. WIFI with the iPhone - my favourite mode, worked really well with 3rd party turntable. Wifi was in the HOST mode, customised SSID and password via mac studio app.

  2. USB - with m1 mac (tried windows device too - I’ll get to that later)

On the weekend, Pop2 ceased to create wifi network. I wasted at least 5h trying to resolve it. I can only operate the POP2 via USB mode now, but getting through POST seems to be random (out of 10 tries, I’d get 3-5 green over USB, the rest ending up with stuck with blue led).

I dusted off an older windows machine from 2014 (the scan seemed smoother than on the much more powerful mac - I’m perplexed by that!). Again with 50/50 chances of getting through POST it works on Windows. I cannot seem to get the WIFI settings to change, as it goes to blue as soon as I press OK on Reset scanner modal.

  • Is there a way to factory reset pop2?
  • Is there a way to access logs (why is there a blue light)
  • Can Wifi chip just stop working after a while? Is it a known issue?
  • Did anyone manage to operate the device in client mode?
  • From the very first use what I’ve noticed mid-startup stage (roughly in the middle of blue led stage) there’s a constant high pitch beep/noise. Is that normal?

I’m still in the window of a 30-day return (EU), considering that, but it seems to me like a buggy software issue that should be resolvable with a factory reset?

Edit: After reading through other reports I wanted to add more context: The WIFI stopped working mid-scan. POP2 was on the tripod. It stopped broadcasting to the phone about 10-13 sec after starting the scan. The scanner was on for maybe 5mins prior to the start of the scan. It wasn’t warm to the touch.

If anyone is interested, I’ve managed to capture the concerning sound (at the end of the recording, it intensifies - that’s because I moved the microphone closer - it’s at constant volume in real life) Hum/noise - recording

There is no Factory reset , once you changed the Host mode you can’t use the original one .

There is log folder under Revopoint but since I don’t use Mac I don’t have the path for you , but I don’t think you will get any answer why it stopping at blue , you can try the to press the 10 times back play button on the device and try to reset it .
You can also try this : [Tutorial] MINI | POP2 | RANGE - Firmware Update Error - Tip | Fix - #6

I never heard of it

Yes you can ask this question @JeffLindstrom as he use client mode with his POP2 and know how to setup it .

I tested so many devices and never heard any beep before , however I heard others did .

Anyway since your POP2 do not reboot correctly I will move this thread to Customer Support for future assistance since nothing else I can help you here with .

I am sure @Revopoint3d-Agnes or @Revopoint3D-Gena will check on this issue with you

If you don’t want to wait until next 9 hours, you can send email directly to customer@revopoint3d.com and add the link to this thread as reference to your issue .

1 Like

Thank you, kind sir. That’s a lot of useful information.

I did try ten times “play button” trick and firmware recovery mode (one with red led), but since it didn’t do anything to network configuration, it’s not helping me. It helps to boot the device in USB mode, though! I was able to change network configuration reliably but to no avail, as the network is simply not created.

I realised the reason I couldn’t connect as a client was that my network has a space in it’s name. Why it’s not allowed in revopoint SSID for 5Ghz network is beyond my understanding. (But since the device doesn’t connect in client mode as well - I suspect a faulty wifi chip).

The beeping is very high pitch and isn’t super audible when recorded on the video, but I’ve used a sensitive instrument microphone and attached the recording above your answer.

I contacted support and located the log file. The log file is from the studio app side, and it doesn’t contain information from the device (for anyone interested, it’s in ‘Users/Username/RevoScanData/log’ on mac).

For full clarity, as I’ve seen the title got changed. The device is able to move past the blue light, I can use it in USB mode with Mac and PC. It doesn’t create wifi network nor connects to one, so I no longer can connect with iphone.

I am sure @JeffLindstrom could help you setting the client mode , he wrote many times in the forum about and how to set up , hopefully he drop by and give you a hand with it.

I know that you can’t return back to the original settings with the host mode wifi after you change it as there is no reset function.

Did you tried to change the host mode settings now when the USB mode is working correctly on PC ? And see if it kicks in ?

If not you will need to contact support again to help you out with this issue .

That’s all I can help you here with

To configure your scanner to work in Client mode (meaning, the scanner connects to your home wifi router and your computer or smartphone is connected to the same router):

  1. Connect your scanner directly to your computer.
  2. Start Revo Scan (you can do steps 1 & 2 in either order, actually).
  3. Verify your scanner is detected by Revo Scan (because the following steps are pointless if it isn’t).

  1. Because of the restrictions in Revo Scan, your home wifi’s SSID (the name you see in the listing) and password cannot have included spaces. Don’t ask me why, it’s just a choice made by the programmers.
  2. Click the Scanner Settings icon at the lower left of the Revo Scan main window.
  3. In the popup, click the Setting button in the Wi-Fi model area.

  1. In the Setting popup, click the Advanced settings button to show everything you see in this image.

Revo Scan - Client Mode 3 - Wi-Fi Settings

  1. Select Client.
  2. Enter the Network Name (aka SSID) and Password where indicated.
  3. Click Confirm.

Now, disconnect the scanner from your computer and connect it to a USB Power Port or a Battery Pack.

If it doesn’t connect, then exit Revo Scan and restart it.

1 Like