POP1 stopped working in USB mode - Android

Hello.

I was previously using my Pop1 with Android RevoScan on a Google Pixel 6A via direct-wired USB, and all was fine.

Recently, I’ve been doing scans on a laptop running RevoScan Windows 10 via USB 3.0 to the laptop and all is fine.

However, now, when I attempt to run RevoScan via USB on the Pixel 6A, the RevoScan program is detecting the POP1 and beginning the scan but as soon as the preview pops up, the app crashes back to the menu.

I tested the RevoScan app on the same Pixel 6A via Wifi hotspot mode and it worked fine. I have a video of the issue that I can send if you give me an address.

Thanks.

- Alex O.

This indicates to me that the problem is with the USB port on your phone.

I had a similar problem with a USB 3.0 port on my laptop that went away when I switched to Wi-Fi.

As PUTV has often recommended, use the Mobile Adapter to provide a separate power supply for the scanner while also connecting to the phone’s USB port for data.

Hi Alex ,as Jeff said already try the mobile connector cable with external power source USBA to power USB C to your phone and see if it works .
Then you are sure if it is your phone OTG issue or the USBC cable .

There is nothing else you can try .
Since that is the phone issue here .

My Android tablet worked for so long then it started reconnecting back and forth without any reason … things happen but I learned one thing to never use the one single cable again on any of my devices .

Thanks. I am using the mobile connector. If you could just give me a location to send a video, you will see everything. If you still think it’s the USB port on the phone after that, then fine. Thanks.

Use Google drive or YT , Dropbox etc there is lots of free services where you can upload the video .
The device is working fine via WiFi or on your computer so really nothing I can help you with here since you already tried everything possible .

It is possible that your new updated driver on your phone cause the crash via USB .
It is hard to tell without actually recreate the issue since it is only related to your specific phone.

Anyway I am moving your thread to Customer Service so they going to check on you and maybe find the reason behind this issue .

In main time please find the free service where you can upload your video , as it will be nesesery for the customer service to evaluate your situation .
I will tag @Revopoint3d-Agnes to follow up on this issue with you .

Thank you. I have uploaded the videos to a Google Drive share and IM’d the link to @Revopoint3d-Agnes

Ok thanks … that will work !

I just realized that my phone stopped connecting to the Pop1 via USB the day the new update for android was released (Dec 21, 2022).

Can I please have a way to revert back to the previous version of the Android app?

  • Alex Olshove

Hi Alex , check in the Starting point Download section for early versions of the app if still available . The stabilizer start button will not works with early version but anything else is actually the same .

1 Like

Thank you for your suggestion but the only download available anywhere is 3.1.3. Can somebody at Revopoint please link me the previous version? If this works for me, it would help your developers recognize that there may be compatibility issues between Pixel 6A, Pop1, and RevoScan 3.1.3.

Then your support would have a resolution for other users to use earlier versions of RevoScan.

Thank you for your time.

  • Alex O.

There are early versions as well
This is 3.0.9 , test it out

2 Likes

Thank you!

  • Alex O.
1 Like

The software is tested based on the release versions of the Android OS , not based on a phone types or made for a specific phone types . If the phone don’t support the basic hardware requirements it will not works .

I had old phone that worked with my old POP1 via USB but the new phone or new tablet did not . And nobody could do anything about that .

The new tablet and phone company support told me to use Hotspot in place of USB …that was their solution :joy:

1 Like

I’ve tried the 3.0.9 and it works again! Thank you!

  • Alex O.
1 Like

Ok Alex thank you for letting me know , so this time it is really on the dev Team to fix it.
What Android version you use ?

I will give you the 3.1.1 version once I get the APK . However any version below 3.1.3 do not support the Stabilizer button what may be the reason why things got broken .

1 Like

Thank you again. That would be amazing and much appreciated.

I am on Android 13. The Stabilizer button is really cool but I could live without it. :slight_smile:

  • Alex O.

P.S. - Remember, I gave the link to the videos I took of the issue to @Revopoint3d-Agnes if they might help the dev team.

1 Like

Thank you Alex , it would be great if you can PM the link as I am on the beta tester team so it would helps to include it on the report .
Thank you

PM’d you. Thanks!

  • Alex O.
1 Like

@aolshove Really sorry that I missed this post, I didn’t receive the video yet, could you please send it to customer@revopoint3d.com and include link to this thread? We will check and reply asap.

Thanks Agnes. This has been completed.

  • Alex Olshove