[Mac] The Beta2 version of Handy Scan

Dear users,

Thank you so much for your feedback on the previous beta version.

Our developer team updated this new Beta2 version with USB mode to solve the below issues:

(1) “Device is connected” first, then remind “No device was found, please plugin.”

Our developers are still working on the following known issues:

  1. Occasionally, the IR camera may not be displayed.

If you encounter this issue, please unplug the POP and restart Handy Scan.

If you’re willing to experiment with this version, please download the installation package via this link: HandyScan V3.1.3_1026_Beta2.pkg - Google Drive

The installation procedure is as follows:

  1. Double click the installation package: * HandyScan V3.1.3_1026_Beta2.pkg* .
    image
  2. Click “OK” when this pop-up appears.
    1
  3. Enter the “Security & Privacy” page under System Preferences.

  1. Click “Open Anyway”.

  1. Click “Open”
    4
  2. Follow the steps to install Handy Scan, click as guided in the following screen caps:
    a) “Continue”
    b) “Install”
    c) “Touch ID or enter your password to allow this.”
    d) “Close”
    5
    6
    7
    8
  3. Click “HandyScan” to start scanning.
    image
  4. Configure the POP when it shows “Device is connected” at the lower left of the main window

Best Regards
Revopoint Team

1 Like

Hi @ottar @Berlin @dfodaro @beanyyz @Rusty @Ziglen @Alexfeenstra @ben1 @Engpete

You can download and test this new Beta version, and see if the USB Mode is available now.

1 Like

Downloaded & installed Beta2 version this morning. Now HandyScan does not even see the device. I check my USB Device Tree in System Preferences & it shows the POP (ZXProduct) as being present but HandyScan does not recognize it. I’ve tried all sorts of combinations of rebooting my computer, rebooting the software, unplugging & replugging in the device all to no avail. I regret to say this seems to be a step backwards as the previous version at least saw the POP & reported it as connected until I pressed either of the 2 blue file folder buttons in the software. :slightly_frowning_face:

it works :smiling_face_with_three_hearts:

it’s so much better than hotspot! the only thing that is not yet correct are the starting values ​​for the brightness in the lower left window. Unfortunately, you cannot make any settings to achieve a perfect result. Thank you Revopoint for your tireless work!

2 Likes

M1 MacBook Air, 16GB ram, Big Sur 11.6.

  1. Scanner is now detected and Handy Scan seems to be able to collect data, but when the stop scan button is pressed the entire app becomes unresponsive. Need to CMD+Q to exit application.

  2. Window size is still cannot be shrunk in size beyond a certain limit. Handy Scan covers more than ~60% of full screen.

I am trying to use it but I noticed that the brightness values ​​do not change, I tried to move the selector but I don’t notice any difference.

Yeah! It is working! It’s still very basic but managed to make a scan of the statue. Is this the maximum amount of detail to expect? Eyes are not visible??? I scanned it with the turntable.



1 Like

the result is okay :ok_hand:t2: you can get an even better result by saving and editing the point cloud

Hello everyone,
I confirm what @Berlin says, if you use the point cloud you get better results.
I am attaching a first test (fossil shell) made with the latest beta of the app (POP connected with the USB C cable) saved as point cloud and meshed with Meshlab on Mac (waiting HandyStudio for mac).


And the mesh from the same point cloud elaborated in HandyScan

2 Likes

It works. But not that detailed i would like. Picture follows

Hello everyone,
Today I have tested the new beta with a Mac Mini M1: The new app work fine (to avoid recognition problems of the scanner connected with the USB cable, it is recommended to first manually delete the old app, if installed, and related files before installing the beta).
And I confirm: if you use the point cloud and created the mesh with other app, you get better results.
Left the mesh created with Meshlab from the point cloud , right the mesh created with HandyScan beta from the same point cloud: the difference is noticeable.

3 Likes

While I’m glad to hear this version worked for so many others on Macs, I’m not one of them. Does this mean I’m out-of-luck and stuck with a POP scanner I can’t use unless I go buy another computer / scanner from another company? Or is Revopoint still working on this? Is this problem due to my using OSX Catalina operating system instead of Big Sur or Monterey (because I have a Wacom device that will not work on the newer systems)?

It’s very disheartening to see POP2 is going to be released soon and I have yet to be able to use this scanner even once :frowning:

Hi @Ziglen,

“Does this mean I’m out-of-luck and stuck with a POP scanner I can’t use unless I go buy another computer / scanner from another company? Or is Revopoint still working on this?”

Please don’t worry. We released a Beta version firstly is to collect users’ problems and solve it before it is officially released on the App Store. We will keep improving our software.

For your problem, I had sent it to our developers, and then we will try our best to find the reason, and solve it as soon as possible.

Btw, did you try the POP with your phone before?

Best Regards
Cassie

2 Likes

if like me you have problems with brightness controls just uninstall handyscan by deleting all the folders also present in the library and reinstall it. On my mac it worked.

2 Likes

I regret I’m severely hearing impaired so the only use I have for cellphones is for connection to the internet & text messaging. Consequently my phone is quite old with insufficient, non-upgradeable memory to successfully use POP - I tried but it could not manage more than a second or so of scanning before it ran out of memory. I might inherit a newer, more capable model when a relative upgrades their phone but at this time I do not know if or when that would be. Buying a new phone just for use with POP is out of the question for me. :frowning:

I also cannot connect with the newest Version. Also first backer :frowning:

Hi @bplutka ,

Could you please send me the screenshot of the “About This Mac” information?

Best Regards
Cassie

Bildschirmfoto 2021-10-30 um 12.04.01

1 Like

Hi @bplutka

Got it with thanks.

Our developer team will try their best to solve this bug as soon as possible.

Best Regards
Cassie

1 Like