[Mac] Revo Scan - 4.1.0.20220918b

Dear users,

The new updated of Revo Scan for Mac is now available on our website. Please check the below link out.
https://www.revopoint3d.com/wp-content/uploads/download/Revo_Scan_for_mac_v4.1.0.20220918b.zip

FEATURE UPDATES:

  1. Added support for the Bluetooth Dual-axis Turntable.
  2. Optimized the texture algorithm and parameters.
  3. Optimized point cloud fusing and meshing.

Please read The Dual-axis Turntable Quickstart Guide below for reference.

Best Regards,
Team Revopoint

4 Likes

Nice. Installed it on my M1 Pro 16" and it runs.
Will test it with the Mini and the turntable later this evening.

FYI, still showing as an Intel app running though Rosetta 2 by the way. It would be really great if this could be made universal eventually.

2 Likes

Installed on my M1 Mac mini.
Firmware update goes well, although I have to force restart the app for couple times.
The dialogue just stuck and doing nothing. Other languages support is missing in this version (beside Eng/Jap/S.Chn).
Dual-axis turntable also works great.

Thanks.

1 Like

Hi Jerry,
Thanks for the feedback. We will keep improving the software. If any further problems or bugs are found, please contact us. Other languages support will be added soon.

Thanks! Please update us if any feedback. And don’t forget to share with us your MINI scans!

Yeah, thanks for your suggestion, our team will take that into consideration :grinning:

Glad to see the Mac update. I downloaded and installed, but the firmware update fails with the following message:

“Unable to get the latest firmware version! Please check your internet connection and try again”

I’m obviously connected to the internet, as I have posted to this forum!

Is there a log somewhere that dhows what URL fetch is failing? Perhaps I can troubleshoot?

-Terence

P.S. Trying to install from central US.

1 Like

I found a log file in $HOME/handylookdata/logs

I ran a “tail -f” on it while I tried the firmware update and only 1 line shows up in the log:

2022-09-20 08:21:57.691 http response data: “Operation canceled” ; error type: QNetworkReply::OperationCanceledError

Hope this helps the Revoteam analyze the problem and issue a fix

1 Like

So I finally got the firmware to update. One of the following (or combination) caused it to succeeed,

  1. I deleted the entire ~/handylookudata directory
  2. I held the power button on the Mini down for about 30 seconds, forcing the device to fully reboot
  3. Or something out of my control changed (firmware availability on server?)

The good news is that now my software has the option to try to connect to the turntable.

The bad news is that the “search” never finds the table. Log files show the following:

2022-09-20 09:04:23.811 ------CBluetoothSetDialog::onSearchFinish(bool isSuccess)–updateMovie(false)-----------
2022-09-20 09:04:48.596 ---------------search-begin search: true
2022-09-20 09:04:48.598 ---------------search-begin code: 0
2022-09-20 09:04:49.602 ---------------search-begin code: 0
2022-09-20 09:04:50.603 ---------------search-begin code: 0
2022-09-20 09:04:51.606 ---------------search-begin code: 0
2022-09-20 09:04:52.610 ---------------search-begin code: 0
2022-09-20 09:04:53.615 ---------------search-begin code: 0
2022-09-20 09:04:54.618 ---------------search-begin code: 0
2022-09-20 09:04:55.620 ---------------search-begin code: 0
2022-09-20 09:04:56.621 ---------------search-begin code: 0
2022-09-20 09:04:57.622 ---------------search-begin code: 0
2022-09-20 09:04:58.625 ---------------search-begin code: 0
2022-09-20 09:04:59.628 ---------------search-begin code: 0
2022-09-20 09:05:00.634 ---------------search-begin code: 0
2022-09-20 09:05:01.639 ---------------search-begin code: 0
2022-09-20 09:05:02.642 ---------------search-begin code: 0
2022-09-20 09:05:03.646 ---------------search-begin code: 0
2022-09-20 09:05:04.650 ---------------search-begin code: 0
2022-09-20 09:05:05.651 ---------------search-begin code: 0
2022-09-20 09:05:06.652 ---------------search-begin code: 0
2022-09-20 09:05:07.655 ---------------search-begin code: 0
2022-09-20 09:05:08.659 ---------------search-begin code: 0
2022-09-20 09:05:09.664 ---------------search-begin code: 0
2022-09-20 09:05:10.669 ---------------search-begin code: 0
2022-09-20 09:05:11.673 ---------------search-begin code: 0
2022-09-20 09:05:12.678 ---------------search-begin code: 0
2022-09-20 09:05:13.679 ---------------search-begin code: 0
2022-09-20 09:05:14.684 ---------------search-begin code: 0
2022-09-20 09:05:15.689 ---------------search-begin code: 0
2022-09-20 09:05:16.694 ---------------search-begin code: 0
2022-09-20 09:05:17.698 ---------------search-begin code: 0
2022-09-20 09:05:18.699 ---------------search-end 0 search : true

-T

P.S. Oh, and if anyone is curious, the download of the firmware took almost 15 minutes, not 1-2 minutes, as the dialog box tells the user. I have gigabit connectivity to the internet and routinely get download speeds of 100 Mbyte per sec, so either the server hosting the firmware is quite slow, or something else is throttling the speed (USB connection to device?). Either way, the revopoint team should consider updating the information to the user to better manage expectations.

1 Like

Same problem here. It gives me the option but never finds the turntable.

I think there’s a bug in the Mac scan program. I was unable to capture color until I realized what was happening. When I scan with the RGB camera light level on Manual, there is not enough light (model is completely black in color view mode). So I tried scanning with the Auto setting on. Problem is, as soon as you start a scan the setting immediately reverts back to Manual. I clicked back on Auto right away (after scanning had started), and thus was able to capture color. In case anyone else is having this problem.

Another thing: Where are my saves going? I’ve saved .obj files with custom names multiple times, and not only are the files not where I saved them, they are nowhere on my computer’s disk (according to a Spotlight search).

Hi @TerenceS,
I am glad to see that you gave us the detailed feedback and suggestion. And I am sorry I didn’t provide help ASAP.
So after reading your replies, can I confirm that the problem now is that the Revo Scan can’t find the turntable? Right? I will ask our tech support to check out the problem.
In normal situation, the upgrade did take like 1-2 minutes. But for some users, when there is a upgrade problem, it takes longer for them to upgrade the software. I will forward this to our team and see if what we can do to improve. Thanks!

Best,
Selina

Hi
I am sorry for the inconvenience.
I have forwarded this to our tech support. Will get back soon with the solution.

Best,
Selina


Please check out the model list and then click the three dots. You shall find where the files are.

Hi
I got the feedback. We would need to see how the problem goes. Would you mind recording a video showing the problem or having a meeting with us?
Thanks in advance.

Best,
Selina

Hi
The setting will revert to manual in case the changing environment affects the scanning.
Please try Auto first, but switch back to Manual before capturing data to prevent lockups.

Thank you for your responses @Revopoint3d-Selina

Unfortunately, I am still unable to connect to the 2ATT.

I have connected to the MINI via USB and the search will not “discover” the 2ATT.
I have also connected the MINI to power via USB/AC* and then connected to the MINI via WiFi. Again, while RevoScan does connect to the MINI (confirmed by the preview feed in the app), when I click on the TT icon and try to “search”, nothing is ever discovered/displayed.

*For USB/AC, I tried all of the following:
MINI USB A cable connected to AC: Unit powers on, but can’t find 2ATT.
MINI USB A+C Cable with only USB C connected to AC: Unit won’t power on (I guess it only draws power from the USB A side)
MINI USB A+C with both A & C connected to AC: Unit powers on, but can’t find 2ATT.
MINI USB A+C with ONLY USB A connected to AC: Unit powers on, but can’t find 2ATT.

-Terence

P.S. The green light on the 2ATT is blinking, which I believe indicates that it is in pairing mode.

If it helps, here is the content of the turntable log… The log represents activity for me opening the app, opening the TT dialog, doing a search (which fails), closing the TT dialog and then closing the app.

% cat turntable_sdk.log
2022-09-24 10:55:43 ---------------------SDK Version Info---------------------
2022-09-24 10:55:43 name:turntablePlugin
2022-09-24 10:55:43 version:V1.0.0.0
2022-09-24 10:55:43 author:penglei,wjh
2022-09-24 10:55:43 date:Sep 16 2022 10:23:13
2022-09-24 10:55:43 desc:create turntable plugin moudle 2022.06.28
2022-09-24 10:55:43 ---------------------------------------------------------
2022-09-24 10:55:43 find plugin failed:/Users/terence/handylookdata/config/plugin/*
2022-09-24 10:55:44 find plugin failed:/Users/terence/handylookdata/config/plugin/*
2022-09-24 10:55:45 load plugin:/Users/terence/handylookdata/config/plugin/libminiTurntable.dylib
2022-09-24 10:55:45 complete load plugin
2022-09-24 10:55:51 queryturntable failed:in scanning
2022-09-24 10:55:52 queryturntable failed:in scanning
2022-09-24 10:55:53 queryturntable failed:in scanning
2022-09-24 10:55:54 queryturntable failed:in scanning
2022-09-24 10:55:55 queryturntable failed:in scanning
2022-09-24 10:55:56 queryturntable failed:in scanning
2022-09-24 10:55:57 queryturntable failed:in scanning
2022-09-24 10:55:58 queryturntable failed:in scanning
2022-09-24 10:55:58 detectTurntable 1110 scanBluetooth read response timeout
2022-09-24 10:55:58 detectTurntable consume:10003ms
2022-09-24 10:55:58 enter enableBluetooth
2022-09-24 10:55:59 queryturntable failed:in scanning
2022-09-24 10:56:00 queryturntable failed:in scanning
2022-09-24 10:56:01 queryturntable failed:in scanning
2022-09-24 10:56:02 queryturntable failed:in scanning
2022-09-24 10:56:03 queryturntable failed:in scanning
2022-09-24 10:56:04 queryturntable failed:in scanning
2022-09-24 10:56:05 queryturntable failed:in scanning
2022-09-24 10:56:06 queryturntable failed:in scanning
2022-09-24 10:56:07 queryturntable failed:in scanning
2022-09-24 10:56:08 queryturntable failed:in scanning
2022-09-24 10:56:08 enable blue tooth failed,no response
2022-09-24 10:56:09 queryturntable failed:in scanning
2022-09-24 10:56:10 queryturntable failed:in scanning
2022-09-24 10:56:11 queryturntable failed:in scanning
2022-09-24 10:56:12 queryturntable failed:in scanning
2022-09-24 10:56:13 queryturntable failed:in scanning
2022-09-24 10:56:14 queryturntable failed:in scanning
2022-09-24 10:56:15 queryturntable failed:in scanning
2022-09-24 10:56:16 queryturntable failed:in scanning
2022-09-24 10:56:17 queryturntable failed:in scanning
2022-09-24 10:56:18 queryturntable failed:in scanning
2022-09-24 10:56:18 detectTurntable 1110 scanBluetooth read response timeout
2022-09-24 10:56:18 detectTurntable consume:10001ms
2022-09-24 10:56:18 enter scanBluetooth
2022-09-24 10:56:18 scanBluetooth 883 not enableBluetooth
2022-09-24 10:56:19 enter enableBluetooth
2022-09-24 10:56:29 enable blue tooth failed,no response
2022-09-24 10:56:39 detectTurntable 1110 scanBluetooth read response timeout
2022-09-24 10:56:39 detectTurntable consume:10001ms
2022-09-24 10:56:39 getInfo failed,turntable is nullptr
2022-09-24 10:56:39 enter scanBluetooth
2022-09-24 10:56:39 disconnect failed,m_turntable=0x0,m_plugin=0x0
2022-09-24 10:56:39 scanBluetooth 883 not enableBluetooth
2022-09-24 10:56:41 unloadplug:miniTurntable-V1.0.0.0

And in case it’s possible the app wasn’t installed correctly, here is the file structure for handylookdata/config…

% ls -lR
total 80
drwxrwxrwx 10 root staff 320 Sep 24 10:55 .
drwxrwxrwx 6 root staff 192 Sep 24 10:31 …
-rwxrwxrwx 1 root staff 16469 Sep 24 10:30 param.json
-rwxrwxrwx 1 root staff 3422 Sep 24 10:30 cmdSetting.json
drwxrwxrwx 3 root staff 96 Sep 24 10:30 plugin
-rwxrwxrwx 1 root staff 0 Sep 24 10:30 project.ini
-rwxrwxrwx 1 root staff 3480 Sep 24 10:55 config.xml
-rw-r–r-- 1 terence staff 0 Sep 24 10:48 bluetooth.ini
-rwxrwxrwx 1 root staff 5249 Sep 24 10:30 turntableCmd.json
-rwxrwxrwx 1 root staff 59 Sep 24 10:30 scene.xml

./plugin:
total 312
drwxrwxrwx 3 root staff 96 Sep 24 10:30 .
drwxrwxrwx 10 root staff 320 Sep 24 10:55 …
-rwxrwxrwx 1 root staff 156984 Sep 24 10:30 libminiTurntable.dylib

Hi Terence,
Thanks for the info.
Please check if you have turned off any firewall and virus-detecting software. And try it again.
If it still doesn’t work, can we have a meeting with you?

Best,
Selina

I’m a bit confused about the guidance to turn off firewall and virus-scan software.

  1. This is a Mac - not windows; and more significantly….
  2. I believe that the bluetooth connection is between the mini and the 2att. Why should any network or cpu processes in my computer interfere with that?

I’m happy to get on a meeting to troubleshoot.

Is there any way to factory reset the 2ATT? I find it odd that when the green light is blinking and it is supposedly in pairing mode that I don’t see any evidence of this device on my Mac or iOS (it doesn’t show up in a Bluetooth discovery/search).

-Terence

P.S. My firewall is currently off and I dont have virus scanning running at this time.

Hi Terence,
Can we have the meeting at 10:00 AM Beijing Time, which is after 30 minutes? Or please let me know when you will be available for the meeting.

Best,
Selina