IOS App crushes after while

Hello, @thenexus
Could you please make sure that your POP is connected to a power bank whose output is over 5V1A?

Hi,

i tested 2 powerbanks (24W - 2USB; 1USB - 2,4A) and a wired usb poweradapter. Also i used the pc usb port (withch work fine with the desktop scan software) but connected the pop to my phone.

All with the same result - scan runs for 10 to 30 secounds then the app slowes down in about 2-5 secounds, tracking is lost and finaly it closes without warning. Memory on the iphone is fine (before you ask ;-)).

thx

Usually if it crashes only because of the power issue.

Could you please send us a video, so that our product team can check and find the problem? Thanks.

Hello,
I’d like to take advantage of this thread, having a similar issue - in my case though, the app crashes as soon as i select “scan” in the app.

Iphone 6
IOS 12.5.3
Same issue even if POP connected to:

  1. powerbank
  2. laptop through usb (it’s working on the windows app)
  3. usb-c power adapter plug (5V 3A)

In the app, I get no info if the scanner is connected or not - I only understand it’s connecting to the hotspot, from the phone’s hotspot menu.
The scanner & app are working correctly on friend’s android phone, with same power supply sources.

looking forward to your reply.
Thank you,
Al

It’s not so easy to make video of myself while make a scan, but i tried my best. Here it is:

In this example it took a while longer until the app crashes. As you can see, it pluged a power control tool betwenn the power bank and the scanner. there is also no peak or loss during scan or before the crash.

Voltage was constant_ 5.09 V
and current between 0.7 and 1.1 Amps

I testet different IPhones:

  • Iphone x
  • Iphone xr
  • Iphone 8
  • Iphone SE (2020)

On PC i got good scanning results.

Thx

Hi, @thenexus
The app crashed because the memory is not enough. We will improve this and add a reminder when the memory is not enough in the future version of Handy Scan.
During this period, you can check this post to do Multiple scans: What can you do when your phone is almost out of memory? - Multiple Scans

Hi, @Alvise87
Your situation sounds a little different with @thenexus, because the app crashes as soon as you select scan.
Could you please also take a video for us to check it immediately?

Hi Cassie,

it took me a while, but here goes the video to show what’s going on.

Connection via hotspot is ok, power supply of the scanner is through my laptop (scans through desktop app works fine).

Thank you for your support!
Al

Hi @Revopoint3D-Cassie , do you have any feedback on this bug?
Thank you,

Al

Hi @Alvise87

Sorry, I forgot to reply to your post.
(1) Could you please try to connect it to a power bank? We still think it is a power issue.
(2) The app version is not the newest, could you please delete the app, then search “Revopoint” in the App Store and re-download it again? Thanks.

Best Regards
Cassie

Hi @Revopoint3D-Cassie ,
a few days after the video I updated the app to v1.4.8.0521.
I tried re-installing the app a couple of days ago, but I see the same build version.
I tried a 2000mAh power bank, and again the laptop usb plug (which works for the desktop app).

The IOs app is not telling me anything regarding adding/finding new devices…
It crashes just like in the previous video.

What can we do? It does not seem a power issue, in my humble opinion.
Thank you!
A.

I have the same issue, and this is a month after the initial post:

I am using a iphone SE 2nd generation, POP scanner powered with a powerbank capable of 2.4A
I am able to launch the app, connect to the scanner, and start a scan. Every time the app crashes so I still haven´t been able to make a scan to check the quality.

Hi @Alvise87

Sorry for the late reply.

Our product team is analyzing this issue. We will try to release a more stabled version.

Best Regards
Cassie

Hi @hcg

I had reported this feedback to product team, and we are trying to find the reason and solve it, thank you for the feedback.

Best Regards
Cassie

Hi Cassie,

I just downloaded the updated app, v.1.4.9.0702, but I am getting the same fault.
In no way the app sees a connection to the scanner, and crashes when trying to scan (like in my first video).

I tried again the same sources as my first post on May 23:

1.powerbank
2.laptop through usb (it’s working on the windows app)
3.usb-c power adapter plug (5V 3A)

Please do look into this issue.
Thank you,
Al

Hi @Alvise87

Sorry so much for the inconvenience caused. We will try our best to find a solution.

Best Regards
Revopoint Team

Hi @Alvise87 @hcg @thenexus

The newest iOS version of Handy Scan is available. Could you please download it and try if the crash issue had been solved? Thank you.

Best Regards
Cassie

Hi @Revopoint3D-Cassie ,

Managed to test it out only yesterday night, it’s now working!
Thank you!

Tested only via power cord supply and not yet powerbank, just fyi.

Again, thank you guys!
A.

Hi @Alvise87

That’s great! Thank you for your feedback.

Best Regards
Cassie