Get frame data error, error code 7, depth-cam not working

Hi!

So this unit of pop2 have been good until, it stopped working. I’m receiving “get frame data error, error code 7”, The LED light behind the pop2 turn green for 1-2 min and afterwards blue, then weaker green.
I tried to uninstall the newest Revopoint scan, installed again (even tried older versions) and no sucess. Even tried to update the firmwire of the unit in Revo Scan.
In Revo Calibration, the unit seems to be on after for some minutes, however the infrared cam does not work.
Ive tried to change the cables, or going over to wi-fi mode, as well no sucess.
Saw one topic in this forum about changing the advanced powerplan settings for usb selective suspend setting, and it is disabled. Still not working.

So if there is other solutions please let me know!
Thanks in advance!

I had the exact, same problem, but going to WiFi fixed it, for me.

I believe extended use (a dozen hours at a time, on multiple occasions) damaged the USB port on my laptop. I switched to WiFi and used a Revopoint-brand power pack; this fixed my problem.

My perception is that the power sources (USB or WiFi) you are using are borderline and cannot support peak power draw.

When you are using WiFi mode, does the scanner’s status LED settle on green after POST?
Does it stay green when you try to scan or does it flicker?
What is the power/current rating for the supply you use in WiFi? (should be 10W or 2A, minimum)

Thank you Jeff for your reply, Ive tried your suggestion on using the “rod” with lithium battery and connect the revo to my laptop through the wi-fi, however the error 7 still pops up. Ive even tried several USB cables (usb 3 and c) connecting directly to my laptop (with different USB ports) and the usb hub and no sucess. Ive even tried 3rd party usb cables. And same error

The IR light itself doesnt light up, the led light behind the revo goes light green then blue, then green then back to light green.

In Wi-fi mode nothing appears in revo scan and the LED sequence of light is the same for USB mode and the WI-FI and the same error 7 pops up in revo scan.

Before the problem of error 7 happened, the scanner was flickering. Im in contact with Leann from revopoint 3D and he asked me to record the proceedings of the scanner.

This indicates to me that you do not have WiFi set up properly. In USB mode (and with a green Status LED), verify the WiFi settings are consistent: Client mode for the scanner, same SSID and Password as your home router, and your computer is connected to the same network.

Good luck, but be sure to configure as listed above.
.