Flickering depth camera

Hello Cassie. I was told to post on this forum by Ela, The Revopoint chat help person. I have an open case with revopoint support [#16519] and you can see documentation through a google drive link in that case. Symptoms are flickering on the depth preview screen and completely erratic scanning no matter what distance, cables or settings are used. This is with iphone ipad and pc (windows 10 i9) and pc windows 8 (i7) absolutely on usb 3.0. the scanner has been calibrated with the application that is on the download website. Also running latest revoscan on ios devices and pc. No matter what the depth camera flickers sometimes with a dark bar and the quality of scans is almost always terrible. out of 5 hours of testing i have had about 10 minutes where it decided to work ok. Let me know if you have any ideas. I am hoping that Agnes and Gena in tech support can offer something I am ready to toss this thing out. GB.

I’m inclined to think that your USB 3 power source is not adequate.

Did you get one of the power banks along with the mobile kit? If so, set up the POP, computer and power bank and try again.

Alternatively, if you have a 10 watt or better USB power brick, use that to power the POP and use a Hotspot or WiFi connection (the latter for the POP 2 only).

Hi Jeff.

I have tried 2 different pcs same results its not the usb3. I have tried multiple wall bricks 2.0 amp. I have tried multiple batteries including the one supplied by Revo. I have tried multiple cables including those supplied by revo. I have tried multiple ios devices by wireless. In short I have tried every conceivable variation of hardware and power delivery. It is not the power supply.

I have reloaded all the software and recalibrated. Still a mess.

While writing this, Revopoint has just contacted me and they believe the device is defective and are trying to decide what the next step is.

Hi, Gene:

From your recount, you were very thorough in narrowing down the probable cause of your problems.

Revopoint has been quite good about replacing the rare squib that gets out the door.

Hello,

I have an similar issue with my POP2. The depth camera is flickering, either on the left area of the preview window or on the right side. Every time the flickering appears in the preview window the scanner is loosing track and it’s impossible to scan an obstacle properly. This behavior happens in all scan modes.

Strangely the scanner sometimes stabilizes and the flickering is gone without any changes done to the environment (same lighting, scanner not moved). In these rare moments it is possible to perform a quick scan that works just fine before the flickering starts again.

I have already tried the suggestions posted in this thread but the flickering in the depth camera remains.

Tried following without success:
-Revopoint power bar as power supply
-USB 3.0 hub with external power supply (20 Watts)
-Newest USB drivers installed on Windows
-Disabled power saving for USB
-Tried with latest Windows Revo scan SW → No success.
-Reinstalled the Windows Revo scan SW from scratch → No success.
-Tried the Android App on my smartphone → No success. Same behavior.
-Tried on my workstation PC and also on a laptop → No success. Same behavior.

How can I fix this issue? Is my device also defective?

Have you used a different USB cable? Several years ago, I had terrible problems keeping my phone charged (I entertained the thought the NSA was tapping my phone, eating up the battery listening to my conversations); it turned out to be a cable with many broken wires, leaving only enough to charge the phone if it was off.

Also, try touching the top center of the scanner after it has been on for 5+ minutes. If it is comfortably warm, then no problem, but if it is almost too hot to bear, then the scanner is defective.

No, I used the original USB cables that were shipped with the scanner. And the issue occurs with both cables, with the cable that is used to connect the scanner to the PC and also with the mobile cable with the USB-C connector to connect to the smartphone and the USB-A connector to attach the power bank.

The scanner top is hot indeed, btw.

revoscan_pop2

@JeffLindstrom
Did you observe the same flickering with your scanner?

@Revopoint3D-Cassie
Is this normal behavior?

adjust the gain setting to lower under your Depth Camera sensor , it don’t have enough points to be captured , setting the proper gain will stop the flickering .

Thanks for your reply.

I don’t think it is related to the gain settings. I tested this by changing the gain setting from min to max for the Depth camera sensor and the detection was always perfectly stable. The distance bar was constantly indicating “Excellent”, no jumps. Also no flickering in the depth cam preview window at all. In this situation the scan worked flawlessly even when capturing more then 300 frames.

When I retried only 15 min later without using the scanner but in the exact same situation, the flickering started again and it was not possible to create a proper scan. Not sure if this is a hardware or software issue. The only change between the two trials was that the charge level of the power bar had dropped from 4 leds to 3 and the scanner heated up.

Unfortunately I can not post videos or gifs here as videos are not supported and gifs are limited to 4MB only.

@Revopoint3D-Cassie
Do you have any other ideas? If this problem can not be solved I will return the scanner or ask for exchange. If it’s too unreliable or even defective hardware it’ll be a pain using it. Please let me know what you think.

Regards.

My reply was based on what I saw in your gif as I can tell the gain level is too great for POP2 to capture anything , if that is the case then it may be related to the IR sensor , I did have sometimes flickering like that but very random and it happening when I use my POP2 for extended time , however I had appointment with the programmer and @Revopoint3D-Cassie via internet and he was able to fix my issues by reinstalling the POP2 firmware and drivers again . If there is greater problem, I am sure they will replace your device as they always do .
I would recommend to send @Revopoint3D-Cassie a PM about it so she don’t miss it here, just in case , otherwise you may waiting too long for response , it is not that she checks every post in the forum on a daily basis , especially as it is posted under Showcase and not under Support section .

All the best

1 Like

Hi @ZapRansom

Sorry for my late reply.

From the current details, I can’t confirm if it is defective or not.

  1. Could you please move the Agrippa further from the POP 2 and see if the situation is still the same?
  2. Could you change another scanned object which is not in white?

Thank you in advance.

Best Regards
Cassie

Hi @Revopoint3D-Cassie ,

No worries.

The situation is still the same even when moving the Agrippa away from the scanner or towards the scanner. Only effect is that the distance indicator is changing from “excellent” to “good”, or “too far”. No improvement in the flickering. Using another object in different color doesn’t have an impact on the flickering either.

Best regards.