Dual-Axis Turntable impossible to connect

With my new Mini I’ve received the dual-axis turnatable but I can’t make it work.

The soft is finding it properly, then it’s connecting to it and few seconds later the light turns off and the soft says ‘not connected’.

I’ve tried with 3 different PCs and different bluetooth adapters but it’s the same…

Is it a well-known issue or is it a problem with mine ? I didn’t find so much topics about these kind of problems.

(sorry for my english : i’m from France).

Thank you the answers

There was an issue with early RS5 release.
Not sure on latest as not tried it yet.

Have you tried with both revoscan v4 and v5 beta? just to help to discard if it is SW or HW related

Don’t think RS5 is beta any more.

1 Like

Tried with RS5 first and RS4 after both installed, but it’s the same.

Perhaps it’s better to try with RS4 only, so I will make a fresh install with RS4 on another PC and try again this WE.

It does work with RS4.

You don’t have to use your PC Bluetooth when connecting your Dual Axis, you need to unpaid it from PC, it will use MINI build in Bluetooth signal automatic .
It works fine in RS4

In RS5 I believe the Bluetooth link between MINI and DATT was removed .
I need to check the last RS5 version on that .

Ok so after that last week-end, I succeed connecting only with RS5 after many tries and it worked ok for a few hours. I don’t know why I succed there.

Then I tried again with RS4 and no hope, the turntable is recognized when it’s blinking green; but when I try to connect, the light stays solid green one or two seconds and then turns off and the software says ‘Disconnected’.

Today, I’ve upgraded RS5 with the latest version 5.0.5 (perhaps my mistake) and nothing works again.

Same story: it turns solid green few seconds when I push connect on the software and the light turns off and the TT goes to the status disconnected with both RS4 and RS5.

I also try with macos Big Sur and Rs4 on a macbook and it’s the same.

Edit: And thank you PopUpTheVolume, I’ve understood last week with ypir explanations that for RS4 It’s better to de-activate the bluetooth inside the PC but for RS5 it’s the bluetooth of the PC that works.

1 Like

I know , the RS5 is unlinked from the scanner Bluetooth and will not use it for connection . It requires the computer Bluetooth to be available .

It is very strange that the green light shutting down , it should not do that , it should blinking until it connect .

It is possible there are technical hardware issues with the Dual Axis turntable as I saw this behavior before .

I will run some tests with the latest RS5 and let you know .

I have exactly the same problem. The dual-axis table can’t be connected to the RS5 Software.
After pressing the button in RS5, the application closes without any message.

1 Like

I will check it again tonight and let you know more …

I just tested V4.3.1 - there it’s working…