Can't update firmware on mini

I finally got around to trying out the Mini today and it says I need to upgrade my firmware. But when I try to do it I get the message “Cannot find latest firmware. Check internet connection…” My internet connection is fine. This is with the latest Mac RevoScan software I just downloaded.

Hhmmm… does your computer or router have a firewall? If so, you may have to manually approve internet access by Revo Scan.

I’m using a Mac at home w/ no antivirus and I don’t believe my cable modem/router has any firewall. At least I’ve never had a problem downloading anything from anywhere before. I suppose it’s possible that it’s using a non-standard port to do the download with? If that were the case though they would have to specify that somewhere.

So… I tried it again tonight. It actually started the update this time. After having to plug and unplug the scanner a couple times because it kept firing up the scanning lights and then stopping and saying it wasn’t connected.
But… It started updating, gave some progress circle things, and finally said update “abnormal” and told me to restart the device. I unplugged and plugged it back in and it then asks if I want to continue. I say yes and it gives the old message again that it couldn’t find the update. It’s not a firewall issue. It is very frustrating.

…and now the scanner will no longer connect. When I plug it in, I just get a blue light on the back. Nothing else and it never goes green. After a while RevoScan asks if I want to continue the update (although it never shows a connected status). If I hit cancel it just brings up the same message in a minute or two. If I hit continue it says it can’t find the update.
So as far as I can tell this thing is now bricked. And I need to figure out how to get support because this doesn’t seem to be the right place.

Sorry about that! Revopoint support really supports you. Adding them to you post makes it easier to see your problem and reach for you. Therefore I am adding some of them. You could also DM to one of them

@Revopoint3D-Gena
@Revopoint3d-Selina
@Revopoint3d-Vivian
@Revopoint3d-Agnes

1 Like

Hi
I am sorry for the inconvenience. Please open api.infly3d.con in the browser. If you can access this website, it means Revopoint’s server is working properly, please check your internet/network Settings instead.

1 Like

Hi GordonAbbott, since the blue light stays after failing to upgrade the firmware, please press the play button of the scanner 10 times, after that the firmware will be reverted to the previous version. And scanner will act normally again.

Now please follow the steps below:

Firstly, check your Mac’s Firewall Settings(Follow the path: Apple logo-System Preferences-Security&Privacy-Firewall), and confirm Revo Scan is not being blocked or Firewall is Off.

Secondly, open api.infly3d.con in the browser, if you can access this website, it means Revopoint’s server is working properly, please check your internet/network Settings instead.
And upgrade the firmware again.

If you can’t access the website(api.infly3d.con), please let me know.

1 Like

Hello,

Seems I’m having a very similar issue. Every time I try to update firmware, the same error message pops up with “Check internet connection.” I’ve checked with an online google test, everything seems running smoothly. I turned off my firewall via McAfee, still doesn’t want to update. And, I clicked on https://api.infly3d.com/, which also seems to be working fine (although it does say “further configuration needed”).

Best,

Rcaranda

Thanks for the help. Good to know about the “play 10 times to revert” feature. After A LOT of retries it finally did the update. Note again that it’s not a firewall issue. It would often do the actual download but it was then hanging up on the install.

BUT… After that I tried to connect to the turntable. If I unplug/plug it in and hold the on button it will blink fast, go through it’s homing routine, and then blink slow. But no bluetooth device shows up on my computer. I checked with my phone too which could detect the next door neighbor’s refrigerator and laptop but not the turntable. I tried shutting everything down and restarting which is when the scanner seems to have truly bricked. After the update I connected and it started up the imaging but now when I connect, it powers/boots up and the back light turns green but the software can no longer connect. Tried maybe 20 times to disconnect/reconnect as well as restarting the scanning software and nothing.

I’ve also tried doing the 10-start thing. No help. I also tried switching from the powered USB hub (which worked fine before the update) to one of the USB ports on the computer. No help.

So far a very frustrating experience.

Hi GordonAbbott, I would like to confirm 2 things with you.

  1. Does the color of the indicator light change before it turns solid green? Please screenshot the firmware version if you still can get the scanner connected to Revo Scan.

If the scanner won’t connect to Revo Scan anymore, please DM me and share the logs folder for the tech team to further analyze the problem and provide the best solution, you can find it this way:

c:\Users\username\handylookdata\logs

  1. Can your phone find the Dual-axis turntable? Can you find 2 names: ZX_POP2 and Dual-AXIS TURNTABLE?

If not, please read this article to troubleshoot first.

Let me know if any of these helps.

Hi Rcaranda, we released the new Revo Scan, please download it and check if you can update the firmware successfully.

Hi Gena,

After a restart of my computer, the scanner will now connect so I think that’s resolved.
The turntable does not show up on any bluetooth scanning. As I said previously my phone also doesn’t detect it when held right next to it and it picks up my neighbor’s refrigerator. I saw the article and I followed the directions and unplugged everything and tried again with no luck.
Just to make it clear again… If I unplug the turntable, plug it in, and press the power button it will begin what I assume is it’s homing routine. While this is happening the green light blinks fast. Once homing is complete the green light blinks slower. During both of these times my computer, RevoScan, and my phone do not detect the turntable on bluetooth.

Hello, I am having the same problem. when try to update the firmware on mac to use turntable, it says internet connection issue check connection. My internet is fine, ive tried the new revo scan as well that you posted above and it is still not working. Ive also reset computer, and the issue still exists. any fix for this please?

Please check out if all your firewall and virus-detecting software are turned off. And then see if you can open this web: api.infly3d.con
If yes, that means the internet setting of Revopoint is working OK, please double check your internet.

I did all the above steps before commenting, ended up just waiting a few hours and closed my laptop and tried now and it worked. now it wont pick up the blue tooth, held the button down for 2 seconds and its beeping, but wont be found

Please check out the methods in this link and see if they help. If not, please provide a video showing the problem. Thanks!

Tried the steps listed in the link, the turntable is not showing up for my Mac, or my phone. The green dot is blinking and can not be found on any devices.

Please provide a video showing the problem. Thanks!

I am unable to upload video here, how can I send the video?