Android can't connect to Range via USB

Hi, I got a Kickstarter Range. and it worked beautifully from the beginning.
Connected to my phone and everything.

I haven’t used it in a couple of months. now I was trying to scan with the same phone and with usb connection the phone doesn’t see the camera at all. in wifi it connects, but when you go to scan it is loading for some time and then says: Camera Exception Failed to get Camera’s information, Please restart the scanner.

It works with the PC.

Would someone have a tip for me, I can try?

Thank you

I moved it to customer service, someone will check on your tonight

You can always write direct to if you have any technical issues …

1 Like

@Waldemar Please press the play button on the scanner 10 times and it will be reverted to the original firmware and the scanner will work again. Please open Revo Scan to check the connection with the scanner.

1 Like

Thank you,
it didn’t work.

I tried having it connected to the power that came with it. on the computer and on usb charger. it’s still the same. I tried with revo scan open and closed, with wifi connected and disconnected, with usb connected to phone and disconnected. I don’t know, maybe i’m missing something.

Thank you for looking into it.


@Revopoint-Mia there was not firmware update performed on Range prior of usage , it simple don’t connect to Android system after long time of being not in use .
Neither any of my scans works via USB on my android phone … the app need to be fixed , as there is nothing wrong with the scanners .

It is OTG issue in relation with the Revo Scan app

1 Like

Hi Waldemar , it is OTG issue , you phone probably updated since last usage , I have the same issue and can only use Range or any other scanner via WiFI on my android phone … not via USB anymore … there is not fixation for that unless the look into the new android updates and try to adapt …

There is nothing wrong with your Range , it is the relation between the android phone updated system and the Revopoint app .

Don’t attempt to reset or fixing your Range …

1 Like

Thank you.

I will try on another phone if hopefully at least wifi works there. Because it doesn’t work at all with my phone.


EDIT: It works with WIFI on my wife’s phone. Same Android S23

At least something Waldemar!
Is that not weird ? The same phones and the other not even picking up WiFI signal from Range while the other do ?
Something got wrong on your phone with the system …

Hopefully they can fix the app soon … so it works proper with the Android system …

Your error code is definitely app issue regarding Range profile in that app , and not your scanner .

1 Like

Yes thank you for pointing that out, I wouldn’t have tried a different phone. and I need the scanner for a job i’m doing right now.