..and another Fimreware-update-fail with POP2

Hi,
I also have the Fireware-update-fail.
Now my POP2 keeps shining blue. I tried the 10-times-klick trick for about hundred times… sometimes slow, sometimes fast … no reaction. It keeps shining blue.
I tried it with the USB A 3.0 cable.
I tried it with just an external Powersupply (from the Premium version).
I tried it with the USB A 2.0 Y-cable only.

Nothing worked.

Is there anything left I can try?

Hi @Lowbird
Here is one more thing you can do , if not working you should contact Customer service via email .

Try this method.

IMG_20221119_081037

1 Like

It really worked out great. Thank you very much.

What is the newest Firmware for the POP2

I don’t have the number under my hand right now but I think it starts with 2.7 and my MINI 2.8 , but if you going to update the firmware again , please wait for the new version of the software next week and then try , not using the one you have right now because if something get wrong you will may be not able to restore your device again .

I am glad to hear it worked !